Announcing V1.7.1 WordPress Story API Plugin Release

May 4, 2018

We are pleased to announce the upcoming release (Monday, May 7, 2018) of an updated WordPress plugin (v1.7.1) for NPR’s Story API.  We’ve added new features and a number of upgrades as well, outlined below:  

  • The Story API box that appears in the post editor has been refreshed:
    • Instead of requiring a separate action to push the story to the Story API, the content will be pushed whenever the content is saved in WordPress, if the "Send to NPR API" box is checked.
    • The box now includes options to include the story for listening in NPR One, and to set the story as "featured" in NPR One. This feature includes the option to set an expiration date, after which time the story will not appear in NPR One.
  • HTTPS is now supported for accessing the Story API. (#44)
  • The push and pull post types are now respected, thanks to #41 from @chrisenterey.
  • PHP 7 is now supported, thanks to #42 from @tjuddill.
  • Several broken links in the documentation have been repaired. (#44)
  • Automated tests are now run against an expanded list of WordPress and PHP versions, as described in pull request #46.

 Frequently asked questions

 

Why should I use the NPR Story API Plugin?

When the NPR Story API Plugin is added to your WordPress site, you can:

  • Publish NPR and other member station stories on your site.
  • Send your content into the NPR Story API to share and collaborate with other stations. 
  • Flag your stories for NPR One inclusion.

 How do I get the plugin?

The newest version of the WordPress plugin will be available on the WordPress plugin directory page. It has also been released as an Open Source projects where collaboration and feedback is welcomed.

If I already have the plugin installed, do I have to uninstall the old version before installing the new version? 

You should not have to uninstall the older version of the plugin. If you are new to updating plugins, this resource may help. Additionally, if you already have the plugin installed, WordPress will prompt you to update. 

Do you have any documentation? 

Comprehensive documentation for configuring the plugin and using its features is provided here.  

What if I find a defect or a problem with the new version? 

Please send us a ticket if you find an issue with the plugin, so we can keep track of issues that arise. 

Do you have any other resources that might help me with this plugin? 

We highly recommend you join the NPR+friends slack, where you will find channel discussing everything from WordPress to the Story API. These communities are quite active and helpful.